1. Bullet Energy 1.3 English

Bullet Energy 1.3 English

  |   84
Bullet Energy 1.3 English
Bullet Energy - This is a new Forum Module for DataLife Engine CMS. Thanks to an amazing structure, lightweight design and clever development as well as modern design and flexible configuration, the component will work stably with any amount of data without creating a heavy load. Ease of configuration and integration of their own design which allows you to run a forum right the way without the high material costs.
Bullet Energy 1.3 English
  1. Additional Information: The conclusion of the latest messages and so on, the converter DLE Forum / Logic Board DLE Edition => Bullet Energy.
  2. Supported versions DataLife Engine: 7.x, 8.x, 9.x
  3. Encoding module: cp1251 and utf-8
  4. Tech. Support: Online Only
  5. Author and developer: white-master (white-master.ru)
  6. Price Bullet Energy:
    • Free software developer's with copyright text= $0
    • Remove the copyright for 1 year - $10 (Purchase)
    • Remove of the copyright for all - $25 (Purchase)
    • Paid technical support for 1 year - $20 (Answers to any questions about the forum). (Purchase)
Datalife Engine 10.2 and 10.3 ONLY
If you are install Bullet Energy in Datalife Engine 10.2 and 10.3, please do the following step in order to make the Bullet Energy Forum compatible...
Open index.php and find:
if( $_SERVER['QUERY_STRING'] AND !$tpl->result['content'] AND !$tpl->result['info'] AND !$custom_news) {
Replace with
if( $_SERVER['QUERY_STRING'] AND !$tpl->result['content'] AND !$tpl->result['info'] AND !$custom_news AND !class_exists('Bullet_Energy_Main')) {
Special thanks: RDN TEAM
Datalife Engine 10.4 ONLY
If you are install Bullet Energy in Datalife Engine 10.4, please do the following step in order to make the Bullet Energy Forum compatible...
Open /engine/modules/main.php and find:
if( $_SERVER['QUERY_STRING'] AND !$tpl->result['content'] AND !$tpl->result['info'] AND !$custom_news) {
Replace with
if( $_SERVER['QUERY_STRING'] AND !$tpl->result['content'] AND !$tpl->result['info'] AND !$custom_news AND !class_exists('Bullet_Energy_Main')) {
PHP 5.4.x Warning!
This forum version will not operation or not function properly if you are using PHP 5.4.x version, especially upload, jquery and JSON functions will not work, so please consider install PHP 5.3.x in order to use this forum version
Login Required!Only registered users can download files. Please register or Login
Dear visitor, you are browsing our website as Guest.
We strongly recommend you to register and login to view hidden contents.

Details

+21

Comments 84

sawanbanna
sawanbanna
DLE TEAM
Commented By sawanbanna on September 29, 2012 (11:00 pm)
Please note the instruction is missing from the installation guide...
Open templates/YOUR THEME/main.tpl and add this before "</head>"
{forumStyle}

Full video introduction with installation and upgrade will be added to our new Documents/User Guide website under Bullet Energy Forum section...

For those who have helped us on Beta Test, please send me your theme so I can design the BE theme that match to your site theme...

Thank you.
31 409Forum topics : 23Forum replies : 979Forum likes : 150

« Live as if you were to die tomorrow. Learn as if you were to live forever! »
nellyville
Commented By nellyville on September 30, 2012 (4:30 am)
I have a problem when i try to upgrade to B.E. 1.3 sad

Warning: require_once(): Unable to access /home/jocuriar/public_html/engine/bullet_energy/library/language/UTF-8/English/install.lng in /home/jocuriar/public_html/upgrade.php on line 11 Warning: require_once(/home/jocuriar/public_html/engine/bullet_energy/library/language/UTF-8/English/install.
lng): failed to open stream: No such file or directory in /home/jocuriar/public_html/upgrade.php on line 11 Fatal error: require_once(): Failed opening required '/home/jocuriar/public_html/engine/bullet_energy/library/language/UTF-8/English/install.lng'
(include_path='.:/usr/lib/php') in /home/jocuriar/public_html/upgrade.php on line 11
31 42Forum topics : 9Forum replies : 34Forum likes : 1

Check my website http://www.Jocuriarena.com
sawanbanna
sawanbanna
DLE TEAM
Commented By sawanbanna on September 30, 2012 (4:54 am)
The problem is in your DLE setting (/language/English/website.lng - adminpanel.lng) is set the charset to all capital (UTF-8 instead if utf-8) so that's why you got this error message...

There are a few ways to fix this easily...
1) login to DLE admin CP and change default charset from "UTF-8" to "utf-8", if doesn't work then it means your language files are not writable chmod, in that case you can manually modify both files website.lng - adminpanel.lng via ftp.

2) (maybe easiest way) rename folder "engine/bullet_energy/library/language/utf-8" to "engine/bullet_energy/library/language/UTF-8"

either way, should work fine...
31 409Forum topics : 23Forum replies : 979Forum likes : 150

« Live as if you were to die tomorrow. Learn as if you were to live forever! »
coisa
coisa
Members
Commented By coisa on October 6, 2012 (2:35 pm)
Warning: include(/home/youpirat/public_html/engine/data/config.php): failed to open stream: No such file or directory in /home/youpirat/public_html/install.php on line 9 Warning: include(): Failed opening '/home/youpirat/public_html/engine/data/config.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/youpirat/public_html/install.php on line 9 Warning: require_once(/home/youpirat/public_html/engine/bullet_energy/library/language///install.lng): failed to open stream: No such file or directory in /home/youpirat/public_html/install.php on line 10 Fatal error: require_once(): Failed opening required '/home/youpirat/public_html/engine/bullet_energy/library/language///install.lng' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/youpirat/public_html/install.php on line 10
N/A 1Forum topics : 6Forum replies : 17Forum likes : 0
sawanbanna
sawanbanna
DLE TEAM
Commented By sawanbanna on October 6, 2012 (9:59 pm)
coisa,
read my comment above.
31 409Forum topics : 23Forum replies : 979Forum likes : 150

« Live as if you were to die tomorrow. Learn as if you were to live forever! »
elka
elka
Members
Commented By elka on October 14, 2012 (12:51 am)
How to make Recent topics box in main page?
N/A 2Forum topics : 0Forum replies : 0Forum likes : 0
noobos
noobos
DLE TEAM
Commented By noobos on October 14, 2012 (4:23 pm)
elka,
please visit this version and get the instruction there
http://www.dlestarter.com/downloads/modules/72-bullet-energy-12-english.html

Display Latest Forum Posts in Main Page
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
eldar
eldar
Members
Commented By eldar on October 15, 2012 (10:08 am)
I installed forum, everything is ok , no errors, but when I try to open "mysite/forum", it says "An error has occurred! No articles found or you do not have access to them." What should I do?
1 4Forum topics : 18Forum replies : 40Forum likes : 0
elka
elka
Members
Commented By elka on October 15, 2012 (10:53 am)
eldar,

Admin CP. (See all functions) At the bottom of the cp.
N/A 2Forum topics : 0Forum replies : 0Forum likes : 0
noobos
noobos
DLE TEAM
Commented By noobos on October 15, 2012 (10:57 am)
eldar,
you are missing .htaccess step.
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
bywide
bywide
Members
Commented By bywide on October 17, 2012 (11:42 am)
Bullet Energy 1.3

Fatal error: Class 'Bullet_Energy_Action_Site_index' not found in /var/www/vhosts/siteadresi.com/httpdocs/abpy/engine/bullet_energy/classes/
main.class.php on line 48

pls help me ...
N/A 2Forum topics : 0Forum replies : 0Forum likes : 0
softonic
softonic
Members
Commented By softonic on November 6, 2012 (4:07 am)
Sir, I have some error with it
When i click on quick edit then it gives error
Fatal error: require_once(): Failed opening required "mysite/engine/classes/parse.class.php' (include_path='.;C:\PHP-Pear\pear') in "my site\engine\ajax\editnews.php on line 66"
&
When i click on full edit then it gives error on \engine\inc\editnews.php on line 32
&
in addnews "\engine\modules\addnews.php on line 25"
N/A 21Forum topics : 34Forum replies : 71Forum likes : 0
noobos
noobos
DLE TEAM
Commented By noobos on November 6, 2012 (4:14 pm)
Your error has nothing to do with Bullet Energy...the error is not coming from BE Forum...check your hack or module you use in your website for add or edit news because the error is coming from that...if you are testing in localhost then make sure you set your site URL correctly in your local site..
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
softonic
softonic
Members
Commented By softonic on November 7, 2012 (7:00 am)
Thanks. You are right sir.
Now it is working fine but giving an error when i click to edit the thred in forum. The error is
{"param":0,"data":"You are not allowed to perform this action."}
N/A 21Forum topics : 34Forum replies : 71Forum likes : 0
noobos
noobos
DLE TEAM
Commented By noobos on November 7, 2012 (9:18 pm)
softonic,
have you added yourself to be moderator? even you are site admin but you must add yourself in the list of global moderator otherwise you can't use the option
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
softonic
softonic
Members
Commented By softonic on November 8, 2012 (6:07 am)
Done sir,
Thanks a lot. Thank you very very much sir
N/A 21Forum topics : 34Forum replies : 71Forum likes : 0
Online
kevinhd
kevinhd
V.I.P.
Commented By kevinhd on November 28, 2012 (5:13 am)
Ooops, Errore!
Requested page was not found.
N/A 19Forum topics : 6Forum replies : 10Forum likes : 0
noobos
noobos
DLE TEAM
Commented By noobos on November 28, 2012 (6:48 pm)
kevinhd,
that means you don't add code in htaccess
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
Dark22
Dark22
V.I.P.
Commented By Dark22 on December 3, 2012 (2:51 am)
Hello Team i installed forum and had some errors but i managed to instal huh tis not was easy lol
Thx to Dlestarter.com and team for this Bord

11 21Forum topics : 56Forum replies : 158Forum likes : 6

Kathryn
Kathryn
V.I.P.
Commented By Kathryn on December 23, 2012 (4:21 pm)
I have a question, mind you this is new to me.. so please bare with my noob question regarding this...
I did not have a problem installing this on 9.7 at all! I am so pleased...however I do not want my menu or anything pertaining to my the sidebar etc just the banner and links I add on top as you have here... How would I do that?
15 47Forum topics : 109Forum replies : 481Forum likes : 6
noobos
noobos
DLE TEAM
Commented By noobos on December 26, 2012 (2:27 pm)
Kathryn,
use standard tags in main.tpl
[not-aviable=forum]
your sidebar in main.tpl here, or anything you don't want to show in forum
[/not-aviable]
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
Kathryn
Kathryn
V.I.P.
Commented By Kathryn on December 27, 2012 (8:01 pm)
noobos,

On the main_forum.tpl? Because all that appears there is :

<div class="navigate_forum">{navigate_forum}</div>
<div class="top_box">[buttom]
  <div class="forum_button">{buttom}</div>
  [/buttom]{speedbar}</div>
{widgetMessage}
{content_forum}
{widgetOnline}


I hope I installed it correctly, I am quite sure I have and am configuring the syle.css somewhat.. But this I am not sure of ... like I said I am a noob at this LOL
15 47Forum topics : 109Forum replies : 481Forum likes : 6
noobos
noobos
DLE TEAM
Commented By noobos on December 28, 2012 (7:56 am)
Kathryn,
no, in your theme main.tpl, to be exact location to the file is
/templates/YOUR-THEME/main.tpl
that file will provide all tags for the rest of the website, forum is only one module so you can exclude or include anything in different section of your site, for example
[not-aviable=feedback]
Whatever inside this section will not show in feedback page when you and visitor browse to feedback form (site.com/index.php?do=feedback)
[/not-aviable]
[not-aviable=register]
Whatever inside this section will not show in register page when you and visitor browse to register form (site.com/index.php?do=register)
[/not-aviable]
[not-aviable=forum]
Whatever inside this section will not show in forum page when you and visitor browse to forum page (site.com/index.php?do=forum)
[/not-aviable]


Combine all together
[not-aviable=feedback|register|forum]
Whatever inside this section will not show in feedback,register,forum page when you and visitor browse to feedback form,register,forum
[/not-aviable]

There is nothing to do with forum theme files, everything is control sections in main.tpl, read more details about tag here http://docs.dlestarter.com/dle-engine/2-basic-main-tag-and-page-displays.html

You can also read a lot of comments in Bullet Energy 1.2 topic about this tag
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
beat
beat
Members
Commented By beat on December 30, 2012 (10:27 am)
I get A error code when i install (www.proinfozone.tk/install.php)
Warning: require_once(/home/a4352061/public_html/engine/bullet_energy/library/language/UT
F-8/English/install.lng): failed to open stream: No such file or directory in /home/a4352061/public_html/install.php on line 10 PHP Error Message Fatal error: require_once(): Failed opening required '/home/a4352061/public_html/engine/bullet_energy/library/language/UTF-8/Engl
ish/install.lng' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a4352061/public_html/install.php on line 10


Please HElp..... sad sad sad sad

N/A 10Forum topics : 1Forum replies : 1Forum likes : 0
asaadshaikh
Commented By asaadshaikh on January 2, 2013 (12:41 am)
hello

how can i change the color of the online group because the normal user and the moderator color is same.


regards asaadshaikh
3 43Forum topics : 14Forum replies : 30Forum likes : 0
CaLy
CaLy
Members
Commented By CaLy on January 2, 2013 (1:29 pm)
I am experiencing some problem with this... I changed the files and all the stuff it says in the last step of the configuration...
But when i want to enter the panel of the forum it says:
Fatal error: Call to undefined method bullet_energy_admin::Init() in /home/tusceleb/public_html/engine/inc/bullet_energy.php on line 24

The line 24 contains
$return = $BE->Init() ;

and nothing more than that ... so what it can be?

Thanks in advance! And have a nice 2013
N/A 2Forum topics : 3Forum replies : 7Forum likes : 0
spamhater
spamhater
DLE TEAM
Commented By spamhater on January 2, 2013 (7:54 pm)
beat,
that means you are using capital charset in your website...by default the charset is using small
utf-8
if you use capital in your website
UTF-8
then rename the folder
engine/bullet_energy/library/language/utf-8
to
engine/bullet_energy/library/language/UTF-8


asaadshaikh,
by default, all group are the same by design...online/offline group are the same green or grey...

CaLy,
based the error it seems like some of BE files missing from your server, make sure to upload them all "again"
24 386Forum topics : 12Forum replies : 950Forum likes : 130

Love is a symbol of eternity. It wipes out all sense of time, destroying all memory of a beginning and all fear of an end!
Great achievement is usually born of great sacrifice, and is never the result of selfishness...Without continual growth and progress, such words as improvement, achievement, and success have no meaning.
noobos
noobos
DLE TEAM
Commented By noobos on January 3, 2013 (2:34 pm)
asaadshaikh,
increase your server memory...
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
noobos
noobos
DLE TEAM
Commented By noobos on January 4, 2013 (12:06 pm)
asaadshaikh,
really?

Show me how did you do it?

show me you php.ini on your host server and how much memory you set for
memory_limit =

If you set to
memory_limit = 256M

or
memory_limit = 512M

That should be more than enough...

But I have doubt that you increase server memory because free host don't allow you to access to php.ini and set memory is located in php.ini and technically only server administrator of the web host provider can access to this file unless the host allow you to create your own php.ini
16 302Forum topics : 12Forum replies : 1036Forum likes : 170
thehamzan6
thehamzan6
Members
Commented By thehamzan6 on January 21, 2013 (7:53 am)
 Call to a member function query() on a non-object in engine/bullet_energy/helper/primary.php on line 64


I keep receiving this error every time I access domain.com/forum

I attempted to clear the forum cache, but the error still persists.
N/A 8Forum topics : 1Forum replies : 4Forum likes : 0
Information!Would you like to leave your comment? Please Login to your account to leave comments. Don't have an account? You can create a free account now.
DLEStarter Notice!Please note...Every hack and every module will get additional queries from your database and some hacks and some modules may result your server overload, so install only what you "need", remove any hacks and modules from your script when you don't need them, all hacks and modules appears in this website are not guaranteed by DLEStarter Team for your script security and compatibility, please read instruction carefully and use hacks and modules at your own risk...Thank you.